computer explosion

so there we were.  playing guildwars.  trying to get some new characters to a high enough level that we can beat the mission which will unlock the ability to go from the nightfall campaign back to the original prophecies campaign.  we’re running aroung collecting XP from the quests we just finished, when, all of a sudden, click, my computer shuts off.

at first i think it’s the monitor.  i have this old 19″ from when we were at college and the color is going which has caused us to a) shop for new lcd flatscreens (cuz I can’t just get on and then be jealous!) and b) swapped monitors so i have the big, but slightly off-color monitor and erin has the color accurate monitor (she seems to do more interesting things with color in graphic design — choices for specific colors when i would go more basic. i decided she needed accuracy more than i did).  so i fiddle with that a bit, and eventually i’m staring at the monitor test thing bouncing across the screen saying “your monitor is working correctly.”  no it’s not, i tell the computer, but it doesn’t listen.

in reality, it is working correctly.  well as correct as it can.  because as it turns out, my character drops off the network in her game and when i try to reboot the computer it does…nothing.  literally nothing.  no happy little beep saying it booted or anything.  i start to get concerned.

first, i try using an ubuntu live cd — i figure if the hard drive went, then i should still be able to boot off the cd.  but after powering the box on, i can’t even get the cd tray to eject.  nothing happens.  i don’t get the pre-operating system self test (POST) screen up, even.  that means there’s something fairly serious wrong along the main brains of the system, the motherboard/processor.

good thing we have the media center, i say, and proceed to pull the new computer that was being used as media center over and swap hard drives.  i figure, the hard drive should still get me into windows and i can just rejoin the game as soon as i swap drives.  but as soon as i swap drives and boot up the new computer with the old drive, i get a bluescreen flash and then reboot.  flash of bluescreen, reboot.  it’s not even up long enough for me to read the error.  so now i’m looking at a bad mobo/proc and hard drive.

so for now the media center is acting as my backup computer until i get new hardware.  i put the original hard drive back in and installed the software i need to do my work.  the only thing lost in this fiasco is just the apps i run, since everything, all my files and everything for web design work, is saved on my server.  ’cause, you know, that was the whole point.  and the server has backups done weekly, so yeah, no harm no foul, just an annoyance, and you know, money.  money that was previously going to my macbook.  /sigh.  i really think the fates are against me in getting this laptop.  i’m going to perservere, though, if it takes every piece of electronics in the house out in the process of getting the laptop.

in completely random other news, however, damn this is a nice machine i built here.  vista runs like a charm, which, you know, is ironic since when i last installed it, it completely trashed my hard drive and led me to vow to never install that piece of trash ever again ever.  this is a much better machine, of course, and newer, and probably really built to run vista (actually, it was precisely built to run vista because the original remote i had only ran on vista, but i ended up having to reinstall it and replaced it with a stripped down vista which didn’t include the requisite driver and i couldn’t get the requisite driver from the manufacturer).  still, it never fails to surprise me to see vista running the way it should.  and fast, too.  so i’ve perhaps changed my mind that it is the spawn of satan.  perhaps…